Exile on Keyboard St. - Blog sur Linux et Debian

Aller au contenu | Aller au menu | Aller à la recherche

lundi 30 janvier 2017

Le Tor Browser Launcher ne fonctionne plus sur Debian ?

La dernière fois que j'ai utilisé le Tor Browser sur Debian, installé avec le paquet torbrowser-launcher, tout fonctionnait parfaitement.

Mais depuis, lors du lancement, le Tor Browser veut télécharger la dernière version du bundle et à la fin ce processus échoue en disant que la signature du fichier téléchargé est incorrecte:

Capture-Tor_Browser.png

J'ai essayé plusieurs fois et j'ai toujours le même message: "SIGNATURE VERIFICATION FAILED".

Dans la configuration du Tor Browser, on peut spécifier si le téléchargement s'effectue avec Tor ou non.

Capture-Tor_Browser_Launcher_Settings.png

Mais que la mise à jour soit faites par Tor ou non ne change rien au problème.

J'aimerai bien pouvoir utiliser ma version 6.0.8 bien qu'elle soit obsolète mais cela semble interdit ... C'est dommage, je le trouvais très commode ce paquet torbrowser-launcher pour utiliser Tor :-(

Je vais donc creuser la piste qui consiste à forcer l'utilisation de la version actuelle ou essayer d'utiliser les autres miroirs mais je pense qu'il y a une régression dans le code de vérification de la somme de contrôle du fichier.

Enfin, désinstaller complètement le paquet et le ré-installer n'a rien donné non plus.

samedi 22 novembre 2014

Google Chrome: et s'il était temps de s'en passer ?

Il y a quelques temps, je pestais sur le fait que le Plugin Flash de Google Chrome en version stable ne fonctionnait plus.

La solution trouvée étant alors d'utiliser Google Chrome en version unstable.

Seulement voilà, depuis ce temps j'ai de plus en plus souvent l'erreur suivante: "Page Web inaccessible"

Google-Maps.png

avec le code d'erreur: ERR_SPDY_INADEQUATE_TRANSPORT_SECURITY

En clair (si je comprends bien) le navigateur Web de Google ne fait pas confiance aux sites ... de Google ! C'est pas beau ça !!!

Donc quand je vais sur google.fr ou Google Maps, j'ai cette erreur une fois sur deux ou sur trois. C'est quand même assez fatiguant ...

D'autant plus que le navigateur fonctionne, c'est à dire que si j'entre l'URL http://www.yahoo.fr, j'accède bien à la page d'accueil de Yahoo. Mais comme le navigateur Google Chrome n'aime pas la saisie d'URL dans la barre d'adresse et que toute saisie est envoyée comme mot clé au moteur de recherche de Google, j'ai du mal à saisir une adresse étant donné que Google Chrome corrige en permanence ce que je saisis !

Donc, je crois que je vais sérieusement réfléchir à me passer une bonne fois pour toutes de Google Chrome, comme cela a été le cas avec Microsoft Windows il y a de cela presque 10 ans, et utiliser uniquement Mozilla Firefox. C'est peut-être également l'occasion de faire un inventaire des différents navigateurs Web sérieux et libres sur Debian.

mercredi 3 septembre 2014

Epiphany: un navigateur HTML5 performant pour le Raspberry Pi

A la fin de l'année dernière, la fondation Raspberry Pi annonçait un nouveau navigateur Web en version bêta optimisé pour l'architecture du Raspberry Pi.

J'avais testé à l'époque ce navigateur nommé Epiphany et j'avais, comme beaucoup, été déçu par les performances de celui-ci.

Depuis hier, le navigateur HTML5 pour Raspbian est disponible en version finale, spécialement optimisé pour l'architecture ARMv6. Il sera le navigateur par défaut dans Raspbian et NOOBS mais on peut déjà l'installer depuis les dépots de ces dernières distributions.

Epiphany est donc à tester de toute urgence par ceux qui veulent pouvoir naviguer sur le Web avec seulement un Raspberry Pi.

samedi 17 mai 2014

Désactiver le géolocalisation dans Firefox

Si comme moi vous en avez marre du popup de Mozilla Firefox qui demande "Casto... veut savoir où vous vous trouvez", sachez qu'il est possible de désactiver la géolocalisation dans Firefox.

Cette option n'est pas paramétrable dans le menu Préférences mais seulement dans les options avancées en entrant l'URL magique about:config dans la barre d'adresse du navigateur.

Il faut alors chercher la clé geo.enabled et mettre sa valeur à false.

Cette valeur devrait d'ailleurs être positionnée comme ça par défaut. En effet, je sais où se trouve le magasin Castorama le plus proche de chez moi, et eux n'ont pas besoin de savoir où j'habite !

Pour plus d'informations sur la géolocalisation dans Firefox sur le site de Mozilla.

vendredi 9 mai 2014

Position des onglets dans l'interface Australis de Firefox 29

Il y a quelques jours Mozilla a rendu public la version 29 de Firefox avec sa nouvelle interface graphique Australis proche de celle de Google Chrome.

Je ne m'étendrai pas maintenant très longuement sur les nouveautés de Firefox 29, un long post serait nécessaire à cela.

Par contre au premier abord un aspect de l'interface Australis me gêne et c'est la position des onglets (tabs) des fenêtres de navigation. En effet les onglets des fenêtres ouvertes se situent AU DESSUS de la barre d'adresse, ce qui n'est pas très pratique pour naviguer d'une fenêtre à l'autre d'un clic de souris:

Untitled.jpg

Heureusement une extension existe pour changer la position des onglets, et bien d'autres paramètres, et c'est Classic Theme Restorer.

Une fois l'extension installée, on navigue vers Outils -> Classic Theme Restorer, et dans l'onglet Principal de la boite de dialogue de configuration de l'extension, on trouve le paramétage des onglets:

Screenshot_-_05092014_-_10_58_40_AM.png

Et c'est là qu'on va changer le deuxième champs en "Onglets position basse".

Si on ne veux pas utiliser l'IHM, on peut aussi utiliser "about:config" et chercher la clé "extensions.classicthemerestorer.tabsontop" à laquelle on associera la valeur "false".

Voilà, maintenant les onglets sont à portée de clic !

- page 1 de 2